Clip Manager 4:Menu Commands and short-cuts

From myFMbutler wiki
Jump to: navigation, search

Main Page > Clip Manager 4 > Menu Commands and short-cuts

Contents

Clip Manager Menu

Clip Manager 4 menu

Command Shortcut Description
About Clip Manager... - Find out about the particular version of Clip Manager you are using.
Check for Updates - Use this command to check if there is an update available.
Provide feedback... - Found a bug, having a feature request or have a question? This is the best way to get in touch with us.
License... - Show the License dialog, where you can enter and review your software license.
Preferences... ⌘, Open Clip Managers preferences window.
Services - System-wide services provided by Mac OS X.
Hide Clip Manager 4 ⌘H Leave Clip Manager 4 open, but hide all its windows.
Hide Others Alt-⌘H Hide all windows of other applications you have open.
Show All - Show all of the windows in all open applications you've hidden using the hide commands.
Quit Clip Manager 4 ⌘Q Quit Clip Manager 4


File menu

Command Shortcut Description
New Clip ⌘N Create a new empty clip. This can be useful if you have the raw XML of a clip in another tool and you want to use it in Clip Manager. Use this if you want to get a Custom Function from the Brian Dunning website.
New Folder Shift-⌘N Create a new sub-folder in the current selected folder in the browser, or create a new snippets folder.
Reveal ⌘R Reveal the current selected folder in the browser or current selected file in the clip list, in Finder.
Delete ⌘-Backspace Delete the current selected folder in the browser or current selected file in the clip list.
Close ⌘W Close/Hide the current window.
Save ⌘S Save current loaded clip.
Save as Shift-⌘S Save the current loaded clip as new file.
Revert - Revert all changes since last save.

Edit menu

Command Shortcut Description
Undo ⌘Z Clip Manager remembers a list of changes you make in the source editor. Choose this command to move one step backwards in the list.
Redo Shift-⌘Z If the last thing you did in the source editor was an Undo, you can step forward to undoing the Undo.
Cut ⌘X Remove the current selection and put it on the clipboard.
Copy ⌘C Copy the current selection on the clipboard. When do a copy in clip view and the Auto Paste function is on, Clip Manager will switch to FileMaker Pro (Advanced) and try to do a paste there.
Paste ⌘V Place the contents of the clipboard in the current selected area. If no area is selected, Clip Manager will create a new clip with the content of the clipboard if it contains a clip. (Same as the "Get" command in the toolbar).
Clear - Clear the current selection.
Select All ⌘A Select everything selectable in the current focused area.
Find > Find Clip Alt-Shift-⌘F Find your most favorite clip.
Find > Find ⌘F Find within a clip.
Find > Find Again ⌘G Choose this to find the next occurrence of the last entered search criteria in the current clip.
Find > Find and Replace Alt-G Do a search and a replace in the current clip.
Find > Replace All Alt-⌘= Do a search and a replace all in the current clip.
Open in external editor Shift-⌘E Open the current loaded clip, in another editor, specified in the preferences.

View menu

Command Shortcut Description
Show Inspector ⌘I Show/Hide the inspector window.
Show Line Numbers Alt-⌘L Show/Hide line numbers in the source editor.
Show Invisible Characters Alt-⌘I Show/Hide invisible characters in the source editor.
Show Clip List Alt-⌘1 Show/Hide the clip list.
Show Browser List Alt-⌘2 Show/Hide the browser list.
Show Clip View Alt-⌘3 Show the clip view.
Show Source View Alt-⌘4 Show the source view.

Go menu

Command Shortcut Description
Back ⌘[ Open the previous opened clip.
Forward ⌘] Open the next opened clip.
Go to line Shift-⌘L Open a dialog to go to a certain line number in the source editor.


Window menu

Command Shortcut Description
Minimize ⌘M Minimize the current window.
Zoom - Zoom the current window.


Help menu

Command Shortcut Description
Clip Manager 4 Help ⌘? Open the Clip Manager 4 help wiki.


Clip Manager 4 Status menu

Command Shortcut Description
Show Clip Manager Alt-M Switch to Clip Manager and show the main window.
Show FileMaker Alt-F Switch to FileMaker.
Copy to Clip Manager Alt-C Copy a clip from FileMaker to Clip Manager and open it.
Record to Clip Manager History Alt-R Copy a clip from FileMaker and save it int Clip Manager History. Useful when the option "Record Clip History" is off in the preferences.
Occurrence Selector Alt-O Show/Hide the Occurrence Selector when in the define database window of FileMaker Pro.
Custom Function Installer Alt-U Show/Hide the Custom Function Installer
Snippets - Direct access to your snippets.
History > Recent Clips - Direct access to the last 10 recorded clips in the Clip History.
History > Favorites - Direct access to the clips marked as favorite in the Clip History.
Personal tools